| 

.NET C# Java Javascript Exception

Installationsprobleme mit jsecurity und shiro

Dies ist das Archiv des ehemaligen Forums zum Thema Groovy, Grails, Griffon und Bean Scripting Framework, welches unter groovy-forum.de existierte. Die neue Adresse des Groovy-Forums ist: http://codekicker.de/fragen/themen/groovy.


Installationsprobleme mit jsecurity und shiro

everd - 26.08.2010 14:56
Hallo Zusammen

Ich bin relativ neu in der Grails-Welt (schreibe gerade meine 2. Applikation), und stelle mich deshalb vielleicht auch einfach etwas doof an...

Auf jeden Fall wollte ich wie gewohnt mit "grails install-plugin jsecurity" das Jsec-Plugin installieren.
Dies klappte eigentlich auch, oder dachte ich zumindest.

Denn wenn ich danach den dbrealm oder den auth-controller erzeugen will, bekomme ich nur die 2 Meldungen, wie sie im Anhang zu sehen sind.
Die entsprechenden Files werden aber leider nicht erzeugt.

Ich habe folgendes schon versucht:
- neuinstallation des plugins
- das Ganze mit Shiro probiert, gleiches Verhalten
- grails clean
- google-Suche

Hat alles nichts gebracht, obwohl ich im ersten Projekt alles genau gleich gemacht habe und es da funktioniert hat.
Wäre toll, wenn mir hier jemand helfen könnte... ich verzweifle nächstens....


lg everd
Dateianhänge:
öffnen | Download - create-db-realm.jpg (77.2 KB)
öffnen | Download - create-auth-controller.jpg (86.5 KB)


Re: Installationsprobleme mit jsecurity und shiro

saurier - 26.08.2010 23:05
Hast du mal

grails quick-start

probiert.

Ich habe gerade mal shiro mit einem neuen Projekt probiert, und das ging ohne Prolbeme. Allerdings Grails 1.3.4

Gruß,
Christian


Re: Installationsprobleme mit jsecurity und shiro

everd - 27.08.2010 10:05
Danke Christian für den Input.
quick-start habe ich auch schon ausprobiert.

Ich habe nun folgendes gemacht:
- Grails auf die Version 1.3.2 updated (1.3.4 bekomme ich nicht als stable-release?)
- alle jsecurity- und shiro-Plugins entfernt (auch alle Files, usw.)
- Shiro neu installiert

leider funktioniert es noch immer nicht.
Wenn ich quick-start, create-db-realm oder create-auth-controller ausführe, bekomme ich eine Error-Meldung.

Ich habe für folgende Punkte Screenshots angehängt:
- Installation Shiro
- ausführen von quick-start

Ich weiss echt nicht mehr weiter und im Netz finde ich auch nichts dazu... :-(

WICHTIG: ich habe noch ein neues Testprojekt angelegt und in diesem das Shiro-Plugin installiert.
Das funktioniert einwandfrei, alle Scripte lassen sich ausführen, usw.???

Gruss
Yves



Dateianhänge:
öffnen | Download - instal_shiro.jpg (128.1 KB)
öffnen | Download - quick-start.jpg (68.3 KB)


Re: Installationsprobleme mit jsecurity und shiro

saurier - 27.08.2010 11:45
Hallo Yves,

Zitat

Grails auf die Version 1.3.2 updated (1.3.4 bekomme ich nicht als stable-release?)

??? 1.3.4 ist doch stable!

Zitat

alle jsecurity- und shiro-Plugins entfernt (auch alle Files, usw.)

Es gibt ein Verzeichnis "scriptCache", hast du das mal geleert? Es sieht so aus, als würde
da noch irgendwas altes benutzt.

Gruß,
Christian


Re: Installationsprobleme mit jsecurity und shiro

everd - 27.08.2010 12:25
Ich habe alles geleert, ausser "ScriptCache"...

Das wars, nun funktioniert alles, vielen vielen Dank :-)

Die neueste Version habe ich nun auch, offenbar stimmt der Link bei grails.org nicht.

Gruss
Yves


Stelle deine Groovy-Frage jetzt!


Diese Seite zeigt den Thread "Installationsprobleme mit jsecurity und shiro" der ehemaligen Webseite groovy-forum.de, welche durch einen Serverunfall zerstört wurde. codekicker.de hat viele Konversationen über die beliebte Programmiersprache Groovy und zugehörige Frameworks wie das Grails-Framework retten können.

Hast Du eine Frage zum Thema Groovy, Grails oder allgemein Java? Viele ehemalige groovy-forum.de Mitglieder beantworten dir auf codekicker.de deine Frage! Stelle jetzt eine Frage!

Viele weitere Diskussionen zu Grails und Groovy befinden sich auf der Threadübersicht des alten groovy-forum.de.