| 

.NET C# Java Javascript Exception

3
Auf meinem Rechner (Windows 7 / IE 9) ist in den IE-Settings die Checkbox "Browserverlauf beim Beenden löschen" angehakt und ausgegraut. Das hat mir bei der Spracheinstellung der Visual-Studio-Hilfe einiges Kopfzerbrechen bereitet. Inzwischen habe ich es zumindest geschafft, das Häkchen wegzubekommen, so dass sich mein IE endlich wieder Cookies merkt. Das ging über den Group Policy Editor, Administrative Vorlagen -> Windows Komponenten -> Internet Explorer -> Browserverlauf löschen -> "Löschen des Browserverlaufs beim Beenden konfigurieren" von "Nicht konfiguriert" auf "Deaktiviert" setzen.

Ich würde aber gerne den "Normalzustand" wieder herstellen und die Checkbox wieder anklickbar machen. (Die "Fernbedienung" über den Group Policy Editor ist auf Dauer lästig ;-)). An gleicher Stelle die Option "Funktion 'Browserverlauf löschen' deaktivieren' zu setzen (bislang auch "Nicht konfiguriert", wie auch alle anderen Einstellungen) hat nichts gebracht. Wo könnte ich noch suchen? Unsere System-Admins bestreiten, dass eine von ihnen gesetzte Policy dafür verantwortlich ist. Ich habe schon gehört, dass der Cisco-VPN-Client, den ich auch im Einsatz habe, sich während einer laufenden Verbindung in die IE-Settings reinhängt und bei einem Crash die Änderung dauerhaft bleibt. Das könnte auch bei mir der Fall sein, aber ich weiß nicht, wo ich jetzt suchen muss. Hat jemand einen Rat?
News:
08.11.2011
Matthias Hlawatsch 13,2k 4 9
3 Antworten
1
Hallo, habe des Rätsels Lösung gerade in nem englischen Forum gepostet...:

Hey guys!

Had the same problem with Internet Explorer 9 but none of the presented solutions did help (cause this is my private PC and so it is not controlled by an IT department). Actually editing the relevant parts with Registry Editor or through Group Policy worked, so they de/activated the IE options respectively grayed them out. HOWEVER regarding the grayed out option 'Delete browsing history on exit', I only managed to alter the setting (checked<>unchecked) but basically the option (Internet options / General / Browsing history) remained grayed out :(
But I found the solution: I remembered that I had used a customization program for my Win7 DVD, called 'WinToolkit'. There I had set up, that browsing history should be deleted by default (in order to have set this option with every coming Win7 installation). So this could be the reason why your box is grayed out! Either you, or your IT-admin has used such a customization tool for the Win7 installation media!

However one can resovle it by deleting some REG-keys which were set by one of these tools. As always: backup the regarding REG-keys before!!!

I had a PC which was installed with an original Win7 DVD media and one installed with the customized DVD media. I compared the REG-keys mentioned all over the internet and found out that my customized Win7 installation had some additional REG-keys. I deleted them, closed the REG Editor, rebooted and everything worked again: the box was active again instead of grayed out :)

So here we go:

1) Click "Start." Type "Regedit" in the Search box and press "Enter." Click the "Yes" button on the UAC dialog. This opens the Windows Registry Editor.

2) Navigate to "HKEY_CURRENT_USER \ Software\ Policies \ Microsoft \Internet Explorer" on the left pane. Right-click it and export the REG-key in order to be able to roll it back if needed.

3) Beneath there should be only one subfolder called "Control Panel" (where the Group Policies are stored). If you find an additional subfolder called "Privacy" delete it! This is the additional REG-key I mentioned above, which causes the 'grayed-out-behaviour'. This 'Privacy-subfolder' does not exist if you installed your PC with an original Win7 DVD media.

4) Now go to "HKEY_LOCAL_MACHINE \ Software\ Policies \ Microsoft \Internet Explorer" on the left pane. Right-click it and export the REG-key in order to be able to roll it back if needed.

5) Again: beneath there should be only one subfolder called "Control Panel" (where the Group Policies are stored). If you find an additional subfolder (in my case there wasn't any additional folder) called "Privacy" delete it! This is the additional REG-key I mentioned above, which causes the 'grayed-out-behaviour'. This 'Privacy-subfolder' does not exist if you installed your PC with an original Win7 DVD media.

6) Close the Registry Editor, restart your computer and you are done. The box shouldn't be grayed out any more.
07.09.2012
Das war's. Danke! Es reichte übrigens (jedenfalls bei mir), den Privacy-Ordner umzubenennen und den IE neu zu starten. (Und falls man prinzipiell die Policies haben wollte, würde es wohl auch reichen, nur den Schüssel zu löschen.)
Matthias Hlawatsch 11.09.2012
Freut mich :) (Dann hat sich meine Registrierung ja gelohnt ;-) )
pustekuchencake 24.09.2012
2
GPOs werden in der Reihenfolge
Lokales Gruppenrichtlinienobjekt -> Standort -> Domäne -> OU
verarbeitet. Da nutzt eine Änderung in dem lokalen Gruppenrichtlinienobjekt natürlich nicht dauerhaft, wenn eine GPO für Standort, Domäne oder Organisationseinheit diese Einstellung ggf. wieder überschreibt wenn der Client GPOs übernimmt.
Zur Lösung deines Problems bist du auf die SystemAdmins angewiesen. Bitte sie doch mal die Richtlinien mit entsprechenden Tools zu analysieren.
10.11.2011
Joachim 3,1k 4 9
Ich kann es nochmal versuchen, aber bei den Admins habe ich ja schon mal nachgefragt, und da kam als Antwort, dass es keine diesbezügliche übergeordnete GPO gibt. Halte ich auch für unwahrscheinlich, es würde einfach nicht zur hiesigen "Admin-Kultur" passen.
Falls eine übergeordnete Richtlinie meine lokale Einstellung überschreibt, dann tut sie es jedenfalls sofort, denn wie gesagt hat eine lokale GPO-Änderung für das Enablen der Checkbox bei mir gar keinen Effekt, nicht mal einen temporären - im Gegensatz zum Setzen des Häkchens, das ich auf diesem Weg dauerhaft beeinflussen kann.
Matthias Hlawatsch 11.11.2011
0
Hast Du so eine selbst editierte Windows 7 DVD für die Installation verwendet?
07.09.2012
Wörtlich genommen: nein, denn ich habe den Rechner nicht selbst aufgesetzt. Was unsere Admins hergenommen haben, weiß ich nicht; aber ich glaube eher nicht, daß die mit drinhängen. Eher habe ich die Installation des Cisco-VPN-Clients im Verdacht. Andererseits ist der inzwischen wieder deinstalliert, aber vielleicht hat der Uninstall da nicht sauber aufgeräumt.
Matthias Hlawatsch 11.09.2012
Wundern würde es micht nicht, wenn die so ne "customized" Installations DVD verwenden - die erleichtert vieles ... manchmal kann sie aber auch ziemlich fuchsen ;)
pustekuchencake 24.09.2012

Stelle deine Internet-explorer-Frage jetzt!