| 

.NET C# Java Javascript Exception

1
Mit Android 4.2 kann ich Widgets nicht nur auf dem Homescreen, sondern auch auf dem Lockscreen ablegen. Ist es erforderlich die SDK-Version im Anwendungsmaifest auf API-Level 17 (= Android 4.2) festzulegen oder erkennt das Android bereits an der gesonderten Anbindung an den Lockscreen?

<uses-sdk android:minSdkVersion=“17“
android:targetSdkVersion=“17“
android:maxSdkVersion=“17“ />
12.02.2013
ElkeR 139 6
1 Antwort
1
maxSdkVersion würde ich eh auf dem neuesten haben.
Um das Fature zu nutzen musst du, wenn ich mich nicht irre, das Projekt so oder so auf die neuesete Version von Android verdraten.
12.02.2013
GENiALi 2,5k 1 2 8
Habe das nochmal versucht nachzuverfolgen und es scheint tatsächlich so zu sein. Danke!
ElkeR 13.02.2013
Es ist wichtig, bei nacholgenden API-Levels die maxSdkVersion hochzusetzen und die minSdkVersion auf 17 zu belassen. targetSdkVersion kann später variiert werden, wobei dies abhängig davon ist, welche API-Funktionen tatsächlich genutzt werden.
ElkeR 13.02.2013

Stelle deine Java-Frage jetzt!