| 

.NET C# Java Javascript Exception

3
Gibts ne möglichkeit, das .net Framework 4.0 unter VB 2005 zu nutzen, oder zumindest einige Bibliotheken???
Also, z.B.
System.Threading
aus dem 4.0 in ein 2005 Projekt einzubinden...
News:
23.02.2011
DerPunk 1,2k 1 7
2 Antworten
5
Meiner Meinung nach dürfte das nicht funktionieren. Du dürftest nicht einmal selbsterstellte .NET 4.0-Assemblies ansprechen können.

Siehe targeting .NET 4 assembly from VS 2005.

The assembly file format in .NET 4 is different from the .NET 2 assemblies. There are backward compatibility, but not forward compatible.

So basically you can't reference a .NET 4 assembly in your .NET 2 project. The option is either get the library back to 2.0/3.x or upgrade the entire project to 4.0.

Zudem wurde die Frage bzgl. ASP mit VS 2008 und NET 4 schon ablehnend auf Stackoverflow beantwortet.

Sieht von daher nicht gut aus für Dein Vorhaben.
23.02.2011
Akkarin 183 4
0
Nein, .NET 4 Assemblies können nicht unter .NET 2 eingesetzt werden.
23.02.2011
Maik_1978 674 1 8

Stelle deine .net-Frage jetzt!
TOP TECHNOLOGIES CONSULTING GmbH